Back to overview
Resolved
Minecraft Network Issue
Sep 18, 2026 at 11:15am UTC
Affected services
DDoS protection
Resolved
Sep 18, 2026 at 11:09pm UTC
A fix has been implemented. All connectivity issues are now resolved.
Affected services
Updated
Sep 18, 2026 at 9:37pm UTC
A issue has been found and a fix is being implemented.
Affected services
Updated
Sep 18, 2026 at 12:48pm UTC
We are now investigating the issue, we will post an update as soon as we have more information.
Affected services
Created
Sep 18, 2026 at 11:15am UTC
Currently a small amount of servers are experiencing network issues causing frequent timeouts. This is due to our upstream provider and we are actively working with them to propose a fix.
Affected services